Hi all,



I am new to osX86.. and Mac too.







I have installed ML with OS X 10.8.4 Mountain Lion bootable USB for Intel PCs Dell Indpiron 620s PC.



downloaded from OS X 10.8.4 Mountain Lion bootable USB for Intel PCs (download torrent) - TPB







At the time of installation: (ie: boot installer USB)



I got white screen only, I did get raid this by sleep/wakeup the PC (ie: when in white screen I pressed power button once, So PC will go to sleep mode, After the I again pressed power button, after this I can see the installer screen.)



Then I proceed with installation. everything was fine...







After installation first time boot was worked fine. (in the same manner said above: sleep/wakeup method.)







From the second boot I got only white screen with mouse







I have tried following fixes: (with the help of ubuntu OS installed in same HD)






  1. replacing ATI6000Controller.kext with kext found in USB installer.

  2. removing (moving to backup dir):



    mv AppleIntelHD* AppleIntelSNB* AMDRadeon* ATI* GeForce* NVDA* /kext_backup

  3. deleting kernel cache:



    rm ../Caches/com.apple.kext.caches/Startup/kernelcache












Tried Boot Flags are: (always -v is used.)






  1. ncpi=0x2000

  2. WithKexts

  3. UseKernelCache=No

  4. GraphicsEnabler=No

  5. -x

  6. -s












I have tried all above combinations. But No Luck :(











Note: I have added following extra kexts from Ubuntu OS:









Quote:









Added: AppleIntelPIIXATA2.kext to fix SATA to ACHI for both installer USB and HD.







Added: FakeSMC.kext from FakeSMC_r615.zip to override kernel panic which I don't remember what was it.







Added: NullPowerManagement.kext to override IntelCPUPowerManagement kernel panic.

















source



source