Hello All,



I would first like to say that the community has been a life-saver as I have been working on this project however I am also in need of assistance and will appreciate any help. I believe my first problem is Im am suffering from information overload.



Heres my situation

I am currently trying to Quad boot my Dell 630m Laptop with the following OSes in this Order Windows 7 Mac OSX Snow Leopard 10.5.8 using ideneb 10.5.6 updated to 10.5.8 and Ubuntu 12.10 on a single 160GB hard drive divide into 4 partitions.



I have been successful in installing all the OSes in their respective partitions, from the terminal results of diskutil list the indentifer is:

Win7: disk0s1

Snow Leopard: disk0s2

WinXP: disk0s3

Linux_Swap: disk0s5

Linux: disk0s6



The problems I dealing with currently consist no sound, Chameleon troubles and Windows XP not booting.



The Sound is an issue I will investigate later in another thread



Chameleon

Part 1

This has been an interesting problem for me first trying to install the Chameleon 2.2 package from here http://www.insanelymac.com/forum/topic/231075-chameleon-22svn-official-pkg-installer-binaries/ however each time following the directions I receive this error Install Failed The installer could not install some files in "/". After reading countless threads on trying to make this work I gave up and started following the directions here http://www.insanelymac.com/forum/topic/164809-how-to-install-chameleon-manually-v-2-and-v-1/ and was able to successfully install Chameleon.



Part 2

After I was able to install Chameleon it broke all of the booting for the OSes I was no longer able to boot anything but heres where I am a bit lost if I used the Chameleon boot cd I am able to boot to Ubuntu and Snow Leopard without the use of any flags but not the Win7 or XP partitions. I know for those two the problem is because the MBR has been overridden by Chameleon so I have to repair this in order for them to work, I have at this point been able to fix the Windows 7 partition however it says that its Recovered. When I use the Boot CD and click on Ubuntu it bring up the GRUB bootloader it alows me to get in Ubuntu so it at least works. Im still working on the XP partition. This now means that Chameleon is gone and I have to use the Boot CD in order to access any of the other OSes and will either have to figure out the SVN or go thru the steps again to manually install Chameleon however if I do I'll be backin the same istuation as before right?



Part 3

As the creation of this thread Im currently using the Chameleon boot CD in order to boot into the OSes which isnt pretty as a normal Chameleon bootloader but honestly I dont know what else to do at this point I cant figure this piece out.



If anyone can help me get over this hump I would appreciate it if you need any additional information please ask Im willing to try anything at this point to make this work.



Thanks for looking and any help



source