Hi,



I'm hoping to perhaps make contact with information regarding getting my Atheros AR9462 chipset to properly work. As of my latest attempt my atheros and atheros21 chipset is not being recognized and thus the process is being aborted by mac (I don't remember the verbatim error produced, it's a com.apple.kextd error however if that helps). I'm fairly certain the problem comes down to the kexts I'm using not being compatible with the Atheros AR9462. I've tried to add in the correct id to the kexts but this also has not worked.



Some additional background information:

MOBO - Asus Sabertooth Z77 UEFI, DSDT-free installation, BIOS settings factory standard with excpection of virtualization turned on (for linux purposes I require this is on)

CPU - Intel i7 3770k



Software build:

2 HDD, Mac OSX on its own, multibooting Win7/Ubuntu/Mac OS x (OSX booted through chainload grub -> chimera -> os x)



Also I should note, the wireless portion of the wifi card (which I believe is routed through usb2.0 cable) is working. I'm assuming this is due to the usb 2.0 cable routed from the actual card. I believe the PCI wireless portion is what's not working, but I haven't confirmed this assumption scientifically. It's just my assumption based on what little I do know about OS X coupled with a basic assessment of the electronic circuitry on the card.



I've done a lot of online research on this chipset and it seems we're all hitting a wall - but here's to hoping someone's figured it out and is willing to share. If all else fails I'll probably break down and invest in a more compatible card since the price of another card is far cheaper than the cost in time of writing a kext from scratch (especially given I don't really know all that much about kexts :P)



Thanks again for any provided assistance,

Krafty





source